NEU! Insider Preview IP3 verfügbar - Fettes Connectivity Upgrade zu den Feiertagen!
Jetzt könnt ihr tausende Geräte mehr anschließen, mit wenigen Klicks: Alexa, Netatmo, Aquara, Bosch, NEFF, Siemens, Gaggenau, Thermador, Constructa, SONOS, hue, somfy, Spotify, NUKI, tado, blink, ring, Gardena, neato, iRobot, Husquarna, Apple Watch, Go-e Charger, fitbit, Google, Weather Underground, telegram, Twitter (wer noch mag) und 700 weitere.
Soviel Connectivity gab es noch nie auf einen Schlag.
Damit Euch nicht langweilig wird. Weitere Info im Wiki: https://elabnet.atlassian.net/l/cp/1yDzrSQU

----------------------------------------------------------------------------------------------------------------------------------------------------------
Hauptversion 3.5.1 verfügbar - Jetzt mit HTTP-API und hunderten Verbesserungen
Info im Forum: viewtopic.php?f=8&t=3831

Palette lässt sich nicht installieren (Zehnder)

Alles rund um Node Red im Allgemeinen und den entsprechenden Docker-Container für den Timberwolf Server im Speziellen.
Forumsregeln
  • Denke bitte an aussagekräftige Titel und gebe dort auch die [Firmware] an. Wenn ETS oder CometVisu beteiligt sind, dann auch deren Version
  • Bitte mache vollständige Angaben zu Deinem Server, dessen ID und dem Online-Status in Deiner Signatur. Hilfreich ist oft auch die Beschreibung der angeschlossener Hardware sowie die verwendeten Protokolle
  • Beschreibe Dein Projekt und Dein Problem bitte vollständig. Achte bitte darauf, dass auf Screenshots die Statusleiste sichtbar ist
  • Bitte sei stets freundlich und wohlwollend, bleibe beim Thema und unterschreibe mit deinem Vornamen. Bitte lese alle Regeln, die Du hier findest: https://wiki.timberwolf.io/Forenregeln
Antworten

Ersteller
amasingh
Reactions:
Beiträge: 15
Registriert: Mo Sep 19, 2022 10:30 am
Hat sich bedankt: 3 Mal
Danksagung erhalten: 2 Mal

Palette lässt sich nicht installieren (Zehnder)

#1

Beitrag von amasingh »

Hallo zusammen,

leider scheint es Probleme mit meinem NodeRed auf dem Timberwolf Server zu geben. Die Palette "node-red-contrib-comfoair 0.0.8" lässt sich nicht installieren.

Code: Alles auswählen

2023-01-11T10:59:57.616Z [err] npm ERR!
2023-01-11T10:59:57.617Z [err]  A complete log of this run can be found in:
2023-01-11T10:59:57.617Z [err] npm ERR!     /data/.npm/_logs/2023-01-11T10_59_38_504Z-debug-0.log
2023-01-11T10:59:57.682Z rc=1
In meiner NodeRed Installation auf dem Synology NAS (Docker) funktioniert es einwandfrei.
Andere Pakete lassen sich installieren.

Jemand eine Idee?

NodeRed Version auf dem NAS: 2.1.5
Auf dem TWS: 3.0.2

Viele Grüße
Dawinder
Zuletzt geändert von amasingh am Mi Jan 11, 2023 12:16 pm, insgesamt 1-mal geändert.
T3500 #892
Benutzeravatar

starwarsfan
Reactions:
Beiträge: 878
Registriert: Mi Okt 10, 2018 2:39 pm
Hat sich bedankt: 566 Mal
Danksagung erhalten: 639 Mal

#2

Beitrag von starwarsfan »

Hallo Dawinder
amasingh hat geschrieben: Mi Jan 11, 2023 12:04 pm NodeRed Version auf dem NAS: 2.1.5
Auf dem TWS: 3.0.2
Ich habe ja von NodeRed nicht wirklich Ahnung aber wenn Du zwei unterschiedliche Major-Versionen einsetzt, dann kannst Du das nicht direkt miteinander vergleichen. Von daher gehe ich schwer davon aus, dass das gewünschte Paket unter NR 3.x schlichtweg nicht funktioniert!? :confusion-scratchheadyellow:
Kind regards,
Yves

- TWS 2500 ID:159 (VPN offen, Reboot nach Rücksprache) - PBM ID:401 - TWS 3500 ID:618 (VPN offen, Reboot nach Rücksprache) - ControlPro - ProxMox - Edomi (LXC / Docker) - ... -

gbglace
Reactions:
Beiträge: 2894
Registriert: So Aug 12, 2018 10:20 am
Hat sich bedankt: 977 Mal
Danksagung erhalten: 1193 Mal

#3

Beitrag von gbglace »

Ja NR 3 ist ziemlich frisch vom letzten Sommer, der gesamte comfoair-Baustein wurde vor über einem Jahr das letzte mal aktualisiert. Ich denke auch das wird einfach nicht mehr zueinander passen.

Gern mal den Entwickler anpingen ob er eine Version für NR 3.x baut.
Grüße
Göran

-- --Timberwolf 2600 Velvet Red-- -- TWS #225 / VPN aktiv / Reboot OK

Hammer
Reactions:
Beiträge: 148
Registriert: Mo Sep 10, 2018 9:17 am
Hat sich bedankt: 62 Mal
Danksagung erhalten: 58 Mal

#4

Beitrag von Hammer »

Hallo Dawinder,

Es liegt an der Version von nodeRed.
Mit der V2 funktioniert es bei mir und mit der V3 nicht.
Da sieht man wieder den Vorteil von Docker, einfach den neuen wieder gelöscht und den alten gestartet, bis es ein Update gibt.

Grüße
Stefan
BildTimberwolf Server 2500 / #210 DEV 18.10.2022 VPN offen & Reboot nach Rücksprache .

Wiregate seit 2011
Antworten

Zurück zu „Docker Container: Node Red“