[Problem] TWS Server 2100 nichtmehr erreichbar

Alles was sonst irgendwie nirgends rein passt.

Ersteller
KellerJ
Reactions:
Beiträge: 3
Registriert: So Apr 14, 2019 8:27 pm
Wohnort: Hunderdorf

TWS Server 2100 nichtmehr erreichbar

#1

Beitrag von KellerJ » Mo Apr 15, 2019 11:21 pm

Habe heute Abend den Zweiten Server (TWS 2100 / timberwolf165) nach ca. eineinhalb monaten ohne Internetzugang
(da er im Schlafzimmer stand, dort kein Lankabel verlegt ist und Wlan direkt neben dem Bett nicht sehr gesund ist und dort sensorwerte testhalber protokollieren sollte und eher einfach keine zeit war) wieder mal ans netzwerk geschlossen um Softwareupdates ein zu spielen.
Vor dem Softwareupdate hab ich sicherheitshalber eine Datensicherung durchgeführt, man weiß ja nie...

Stand war V1.0 Beta 14

Update auf v1.0 Beta 20

Nach dem Update war der Server ganz normal via Netzwerk zu erreichen, jedoch fiel mir dann doch recht schnell auf, dass alle Datenreihen weg waren! :crying-yellow: :crying-yellow:

Als ich demzufolge eine Wiederherstellung durchführen wollte, war der Server nach starten der Wiederherstellung nichtmehr erreichbar, auch nach 15 minuten nicht. Weder der direkte zugang über IP Addresse, noch über timberwolf165.local funktioniert
Im Router, wird er jedoch noch angezeigt!

Im browser bekomm ich nur noch folgende Fehlermeldung:

Bild

Mir ist noch ein kleines Detail aufgefallen:
Der Server ist als TWS2100 bestellt worden, ist auch in enem 2100er gehäuse drin, auf den Etiketten steht jedoch beidesmal TWS2400!!
Könnte hier ein Konflikt der software evtl irgendwelche Probleme verursacht haben?

PS: Der Hauptserver läuft einwandfrei, der kleinere ist aktuell noch nicht wirklich im Einsatz gewesen, daher herrscht jetzt nicht die mega Panik!!!
Zuletzt geändert von KellerJ am Mo Apr 15, 2019 11:38 pm, insgesamt 1-mal geändert.
TWS2600 - timberwolf194 - v1.0 Beta 20 - 3x 1WBM - VPN aktiv - Reboot OK
TWS2100 - timberwolf165 - v1.0 Beta 20 - derzeit nicht erreichbar


StefanW
Elaborated Networks
Reactions:
Beiträge: 1706
Registriert: So Aug 12, 2018 9:27 am
Wohnort: Grafing
Hat sich bedankt: 233 Mal
Danksagung erhalten: 786 Mal
Kontaktdaten:

#2

Beitrag von StefanW » Di Apr 16, 2019 7:52 am

KellerJ hat geschrieben:
Mo Apr 15, 2019 11:21 pm
Als ich demzufolge eine Wiederherstellung durchführen wollte,
Was hast Du genau gemacht? Wiederherstellung aus Werkszustand? Rücksicherung aus Backup?

==> Ganz allgemein raten wir in einem solchen Fall, also Datenreihen weg nach Update, zuerst zu einem Reboot und dann erstmal hier darüber schreiben und das VPN öffnen, dann sehen wir uns das erstmal an, bevor man Maßnahmen der Wiederherstellung probiert.


lg

Stefan
Stefan Werner
Product Owner für Timberwolf Server, 1-Wire und BlitzART der Elaborated Networks GmbH
Support nur über dieses Forum und in individuellen Fällen über support@wiregate.de.
Bitte KEINE PN Impressum und Datenschutzerklärung oben


Ersteller
KellerJ
Reactions:
Beiträge: 3
Registriert: So Apr 14, 2019 8:27 pm
Wohnort: Hunderdorf

#3

Beitrag von KellerJ » Di Apr 16, 2019 8:38 am

Erstmal danke für die sehr schnelle Antwort @StefanW

Die Wiederherstellung war aus einem Backup, welches zuvor erstellt wurde.

Den Restart nach dem Update hatte ich ausgeführt, da sowas ja ratsam ist.

Hab heute morgen, da der TWS immer noch nicht erreichbar war und ja die nacht an zeit verstrichen war, den server ausgestecht, 10 min gewartet und ihn dann wieder eingesteckt
Resultat: er scheint ganz normal zu booten, die gewohnten töne sind auch in gewohnter zeit zu hören, aber via Webbrowser ist er weiterhin nicht erreichbar.
Was ein freischalten der VPN leider für mich unmöglich macht.

Beim Verbindungsversuch mit dem handy über chrom kam dann die Fehlermeldung dass die Verbindung abgelehnt wurde:

Bild
TWS2600 - timberwolf194 - v1.0 Beta 20 - 3x 1WBM - VPN aktiv - Reboot OK
TWS2100 - timberwolf165 - v1.0 Beta 20 - derzeit nicht erreichbar


StefanW
Elaborated Networks
Reactions:
Beiträge: 1706
Registriert: So Aug 12, 2018 9:27 am
Wohnort: Grafing
Hat sich bedankt: 233 Mal
Danksagung erhalten: 786 Mal
Kontaktdaten:

#4

Beitrag von StefanW » Di Apr 16, 2019 9:37 am

KellerJ hat geschrieben:
Di Apr 16, 2019 8:38 am
Die Wiederherstellung war aus einem Backup, welches zuvor erstellt wurde.
Nur damit ich das richtig verstehe:
  • Du hast mit Softwarestand BETA 14 ein Backup gemacht
  • Dann auf Softwarestand BETA 20 upgedatet
  • Anschließend vom "alten" Backup (und damit die Datenstrukuren der BETA 14) über die BETA 20 restauriert?
Falls das so gelaufen ist, wirst Du vermutlich den Server einschicken müssen (bitte Ticket eröffnen unter support at wiregate dot de). Ein Backup von früheren Versionen sollte man nie ohne Rücksprache mit dem Support zurückspielen (zumindest nicht, bevor man nicht zuvor ein erneutes Backup vom aktuellen - geupdateten - Stand gezogen hat).

Sorry für die Umstände.

Stefan
Zuletzt geändert von StefanW am Di Apr 16, 2019 9:38 am, insgesamt 1-mal geändert.
Stefan Werner
Product Owner für Timberwolf Server, 1-Wire und BlitzART der Elaborated Networks GmbH
Support nur über dieses Forum und in individuellen Fällen über support@wiregate.de.
Bitte KEINE PN Impressum und Datenschutzerklärung oben


Ersteller
KellerJ
Reactions:
Beiträge: 3
Registriert: So Apr 14, 2019 8:27 pm
Wohnort: Hunderdorf

#5

Beitrag von KellerJ » Di Apr 16, 2019 9:55 am

StefanW hat geschrieben:
Di Apr 16, 2019 9:37 am
  • Du hast mit Softwarestand BETA 14 ein Backup gemacht
  • Dann auf Softwarestand BETA 20 upgedatet
  • Anschließend vom "alten" Backup (und damit die Datenstrukuren der BETA 14) über die BETA 20 restauriert?
Genau so war es
Dann war das wohl ein Fehler meinerseits, dass ich ihm da ein "altes" backup drübergebügelt hab :angry-banghead:

Sorry schonmal für die entstandene Arbeit für euch
TWS2600 - timberwolf194 - v1.0 Beta 20 - 3x 1WBM - VPN aktiv - Reboot OK
TWS2100 - timberwolf165 - v1.0 Beta 20 - derzeit nicht erreichbar


shoko
Reactions:
Beiträge: 1
Registriert: Di Apr 16, 2019 11:24 am

#6

Beitrag von shoko » Di Apr 16, 2019 11:30 am

Das heisst ja dann im Umkehrschluss, dass Backups mit jedem Update mehr oder weniger wertlos werden und man sie nicht ohne Support einspielen kann?
Und dass man als Anwender eigentlich kein Backup vor dem Update machen kann um selbständig auf einen funktionierenden Stand zurückzukehren falls beim Update was schief läuft?
Soll das so bleiben, oder wird das noch verbessert?

Benutzeravatar

gurumeditation
Reactions:
Beiträge: 101
Registriert: Mo Aug 13, 2018 10:51 am
Wohnort: Hannover
Hat sich bedankt: 14 Mal
Danksagung erhalten: 35 Mal

#7

Beitrag von gurumeditation » Di Apr 16, 2019 11:35 am

Gute Frage, zudem in der "Anleitung" für jede neue Betaversion bislang drin stand, man solle vor und nach dem Update ein Backup machen...
Das davor ist dann ja ziemlich unbrauchbar falls etwas schiefgeht.
--
TWS 2500 (ID=137), PBM, Wartungs-VPN=ON, Reboot aktuell jederzeit erlaubt


StefanW
Elaborated Networks
Reactions:
Beiträge: 1706
Registriert: So Aug 12, 2018 9:27 am
Wohnort: Grafing
Hat sich bedankt: 233 Mal
Danksagung erhalten: 786 Mal
Kontaktdaten:

#8

Beitrag von StefanW » Di Apr 16, 2019 12:19 pm

Das Backup vor dem Update, das wir empfehlen, ist vor allem dafür da, dass unser Support dieses nutzen kann, es ist also keinesfalls unbrauchbar.

Im übrigen sind Backups immer sinnvoll vor jeder größeren Veränderung. Das gilt grundsätzlich für jede IT.

Rücksicherungen sind grundsätzlich mit Vorsicht zu genießen, insbesondere über Updates hinweg, auch das gilt für alle IT Systeme weltweit gleich, daher empfehlen wir ja auch das erneute Backup nach dem Update.

Wir haben darüber nachgedacht, den Restore (und andere Funktionen) grundsätzlich zu versperren, aber damit würden wir auch diejenigen ausschließen, die die Freiheit behalten wollen, das zu nutzen.

lg

Stefan
Stefan Werner
Product Owner für Timberwolf Server, 1-Wire und BlitzART der Elaborated Networks GmbH
Support nur über dieses Forum und in individuellen Fällen über support@wiregate.de.
Bitte KEINE PN Impressum und Datenschutzerklärung oben


773H
Reactions:
Beiträge: 38
Registriert: Mo Okt 15, 2018 9:24 pm
Hat sich bedankt: 10 Mal
Danksagung erhalten: 15 Mal

#9

Beitrag von 773H » Mi Apr 17, 2019 7:36 am

War der Grund für das "Verbot" einer Rücksicherung von Sicherungen alter Beta-Versionen auf eine neuere Beta-Version nicht, dass mit den Beta-Updates auch Firmware-Updates aufgespielt werden und dadurch evtl. Hardwareinkompatibilitäten entstehen können? Vielleicht sollte man das nochmals deutlich an einer prominenten Stelle den Foristen und sonstigen Lesern mitteilen?

Gruß
Stephan
TWS 2500 SN220 Version 1.0 Beta 20, 2 PBM SN495 & SN632 FW 0.101, ETS 5.7.1, VPN offen, Neustart - wat mutt, dat mutt


StefanW
Elaborated Networks
Reactions:
Beiträge: 1706
Registriert: So Aug 12, 2018 9:27 am
Wohnort: Grafing
Hat sich bedankt: 233 Mal
Danksagung erhalten: 786 Mal
Kontaktdaten:

#10

Beitrag von StefanW » Mi Apr 17, 2019 11:04 am

773H hat geschrieben:
Mi Apr 17, 2019 7:36 am
War der Grund für das "Verbot" einer Rücksicherung von Sicherungen alter Beta-Versionen auf eine neuere Beta-Version nicht, dass mit den Beta-Updates auch Firmware-Updates aufgespielt werden und dadurch evtl. Hardwareinkompatibilitäten entstehen können?
Auch das ist eine Sache, aber das sehen wir eher über die Jahre kritisch und in Verbindung mit "Rücksetzen auf Werkszustand". Das Backup betrifft die Daten, nicht die Programmstruktur.

Wir werden an einer besseren Erklärung und Info arbeiten, aber die Erfahrung zeigt, dass es einfach nicht jeder ließt. Womöglich kann man auch eine Sperre einbauen, damit es nicht so einfach ist, aber wofür sollen wir das Budget der Kunden anlegen? Für eine immer mehr narrensichere Bedienung oder für neue Leistungsmerkmale?

Ich denke, die Mehrzahl der Kunden will neue Leistungsmerkmale und für den Verkauf brauchen wir die ebenso.

lg

Stefan
Stefan Werner
Product Owner für Timberwolf Server, 1-Wire und BlitzART der Elaborated Networks GmbH
Support nur über dieses Forum und in individuellen Fällen über support@wiregate.de.
Bitte KEINE PN Impressum und Datenschutzerklärung oben

Antworten