ioBroker@Timberwolf im Container (mit Video)

Informationen über Docker, Verwaltung mit portainer und VMs
Antworten

NetFritz
Reactions:
Beiträge: 37
Registriert: Sa Okt 13, 2018 4:23 pm
Danksagung erhalten: 4 Mal

Re: ioBroker@Timberwolf im Container (mit Video)

#71

Beitrag von NetFritz » Mi Apr 17, 2019 1:22 am

Hallo
Problem gelöst.
In die /etc/influxdb/influxdb.conf habe ich noch folgendes eingetragen.
Off Topic
[http]
enabled = true
bind-address = ":8086"
auth-enabled = false
log-enabled = true
write-tracing = false
pprof-enabled = false
https-enabled = false
Dann ein Restart und es lief dann.
Gruß NetFritz
TWS 2400 #109 VPN offen, Reboot jederzeit


gospelrock
Reactions:
Beiträge: 64
Registriert: Mo Sep 24, 2018 3:40 pm
Wohnort: Wildau
Hat sich bedankt: 9 Mal
Danksagung erhalten: 21 Mal

#72

Beitrag von gospelrock » Do Mai 09, 2019 9:43 pm

Hallo,
ist es schon möglich den ioBroker auf den Hutschienenservern in einem Dockercontainer laufen zu lassen?
Habe heute versucht nach dem Video das Teil zu installieren und bin daran gescheitert, dass er das beschriebene Image nicht gefunden hat.

Gruß,
Peter
Wiregate1784, Timberwolf 950Q #265, PBM 3x40 Slaves
Wartungs VPN offen; Restart jederzeit möglich


zitterfritz
Reactions:
Beiträge: 6
Registriert: Mi Dez 19, 2018 8:23 pm
Hat sich bedankt: 3 Mal
Danksagung erhalten: 4 Mal

#73

Beitrag von zitterfritz » Do Mai 09, 2019 9:55 pm

Hallo,

versuch es mal mit folgendem Image: jakobwesthoff/rpi-iobroker:latest

Hat damit bei mir auf dem 960Q geklappt.

Gruss,
Heiko
TWS 960Q ID:230, BETA 24, VPN offen, Reboot erlaubt


eumel
Reactions:
Beiträge: 16
Registriert: Sa Sep 08, 2018 4:31 pm
Hat sich bedankt: 5 Mal
Danksagung erhalten: 11 Mal
Kontaktdaten:

#74

Beitrag von eumel » Mo Jun 24, 2019 10:43 am

Hallo zusammen,

ich versuche auch gerade ioBroker auf meinem 950 zum laufen zu bringen. Ich habe das Image von zitterfritz (jakobwesthoff) verwendet. Leider stoppt sich der Container nach wenigen Sekunden immer von selbst.

Bild

Hat jemand bereits ioBroker auf dem 950/960 erfolgreich am laufen und kann mir noch Tipps oder ein anderes Image nennen?

Gruß
Zuletzt geändert von eumel am Mo Jun 24, 2019 10:51 am, insgesamt 1-mal geändert.
TW950q ID:313, VPN offen, Reboot nach Rücksprache


John
Reactions:
Beiträge: 10
Registriert: Mi Nov 28, 2018 2:38 pm
Hat sich bedankt: 3 Mal
Danksagung erhalten: 3 Mal

#75

Beitrag von John » Mo Jun 24, 2019 11:15 am

Ich habe diesen auf dem 950Q laufen:
https://github.com/angelnu/docker-ioBroker

PS: Es ist multi-arch und sollte theoretisch auch auf den Dekstop Servern laufen. Wenn das jemand testen kann, könnte man die Anleitung dahingehend anpassen und für die Desktop + Hutschiene die gleiche Anleitung verwenden.
TWS 950Q #300, VPN aus


eumel
Reactions:
Beiträge: 16
Registriert: Sa Sep 08, 2018 4:31 pm
Hat sich bedankt: 5 Mal
Danksagung erhalten: 11 Mal
Kontaktdaten:

#76

Beitrag von eumel » Mo Jun 24, 2019 12:08 pm

Hallo,

danke für den Tipp! Das von John empfohlene Image läuft und ich kann ioBroker wie in der KB beschrieben über die Konsole starten. Jedoch kann ich noch nicht auf die Weboberfläche von ioBroker zugreifen. Sind dazu noch spezielle Netzwerkeinstellungen erforderlich?

Aktuell bin ich auf bridge und habe den Port aus der KB gemappt. Der ioBroker ist darüber jedoch nicht erreichbar.

Bild

Bild

Bild

Gruß,
Stefan
TW950q ID:313, VPN offen, Reboot nach Rücksprache


John
Reactions:
Beiträge: 10
Registriert: Mi Nov 28, 2018 2:38 pm
Hat sich bedankt: 3 Mal
Danksagung erhalten: 3 Mal

#77

Beitrag von John » Mo Jun 24, 2019 12:17 pm

Ich glaube es war dort der Port 8082 und nicht 8081.
Alternativ in der Kommandozeile nachschauen oder die admin instance dort ein zweites Mal auf Port 8081 starten (iobroker add admin --enabled --port 8081)
TWS 950Q #300, VPN aus


eumel
Reactions:
Beiträge: 16
Registriert: Sa Sep 08, 2018 4:31 pm
Hat sich bedankt: 5 Mal
Danksagung erhalten: 11 Mal
Kontaktdaten:

#78

Beitrag von eumel » Mo Jun 24, 2019 12:46 pm

Hab es sowohl mit einer neuen Instanz unter Port 8081 (iobroker add admin --enabled --port 8081) als auch direkt unter dem Port 8082 versucht. Leider ohne Erfolg. Hast du noch weitere Ideen?
TW950q ID:313, VPN offen, Reboot nach Rücksprache

Antworten