[Problem] [V 1.5.3 ]Apple Home-Kit Plug-In(openHAB) Hohe Zeitverzögerung

Alles rund um OpenHAB im Allgemeinen und den entsprechenden Docker-Container für den Timberwolf Server im Speziellen.
Antworten

Ersteller
Guestgiver
Reactions:
Beiträge: 18
Registriert: Fr Okt 12, 2018 8:51 pm
Wohnort: Niederkassel
Hat sich bedankt: 21 Mal
Danksagung erhalten: 14 Mal

[V 1.5.3 ]Apple Home-Kit Plug-In(openHAB) Hohe Zeitverzögerung

#1

Beitrag von Guestgiver »

Hallo zusammen,

Ich habe vor kurzem openHAB im Docker zum laufen gebracht. OpenHAB greift direkt über die TWS-Schnittstelle auf KNX zu.
Anschließen habe ich das Apple Home Kit PlugIn in openHAB installiert und mit ein paar Schalt und Temperatur-Objekten verknüpft.

Das ganze funktioniert auch prinzipiell schon ganz gut. Allerdings habe ich beim betätigen eines Lichtschalters über die Home-App aufm iPhone eine Zeitverzögerung von mehreren Sekunden bis das Aktor dann tatsächlich schaltet. Die Zeitverzögerung ist eigentlich immer Unterschiedlich, mal gehts schnell mal dauert es 10 Sekunden. :confusion-helpsign:

Meine Einstellungen sehen wie folgt aus:
► Text zeigen
Hat schon jemand Erfahrungen damit? evtl. läuft das ja mitder Alexa integration ähnlich ab?

An dieser Stelle auch nochmal ein großes Dankeschön an die Ersteller der beiden Anleitungen in der KB zu openHAB und Alexa. :clap: :handgestures-thumbupright:
Zuletzt geändert von Guestgiver am Sa Feb 08, 2020 8:39 pm, insgesamt 2-mal geändert.
Timberwolf Server 950Q ID:317, VPN offen, Reboot nach Absprache

gbglace
Reactions:
Beiträge: 1736
Registriert: So Aug 12, 2018 10:20 am
Hat sich bedankt: 608 Mal
Danksagung erhalten: 646 Mal

#2

Beitrag von gbglace »

Deine TWS-Software Version?

Gehen andere Telegramme weiterhin verzugsfrei?

Wenn der KNX-Bus nicht geflutet wurde durch die OH-Installation (Busmonitor prüfen) dann muss man mal Die IP-Netzwerkkommunikation prüfen ob da ein Overflow existiert. Oder der Container / OH haben ein Problem, da dann aber mal echte OH Experten suchen, das wäre vermutlich unabhängig vom TWS.
Grüße
Göran

-- --Timberwolf 2600 Velvet Red-- -- TWS #225 / VPN aktiv / Reboot OK

Robert_Mini
Reactions:
Beiträge: 2509
Registriert: So Aug 12, 2018 8:44 am
Hat sich bedankt: 619 Mal
Danksagung erhalten: 1194 Mal

#3

Beitrag von Robert_Mini »

Also Alexa über OpenHAB schaltet in ca. 1.2sec ab Ende Sprachbefehl.
Ein Teil ist da aber schon die Totzeit, bis Alexa den Befehl als abgeschlossen erkennt (wobei ich vermute, dass die Übertragung unmittelbar beginnt).

Lg
Robert
Timberwolf Server 2500 / #117 (VPN offen + reboot nach Rückfrage) / Wiregate-Fan

Ersteller
Guestgiver
Reactions:
Beiträge: 18
Registriert: Fr Okt 12, 2018 8:51 pm
Wohnort: Niederkassel
Hat sich bedankt: 21 Mal
Danksagung erhalten: 14 Mal

#4

Beitrag von Guestgiver »

TWS Version ist 1.5.3.

Normale KNX zu KNX Telegramme also über nen Glastaster ne Lampe schalten gehen ohne Zeitverzögerung.
Über CometVisu auf dem TWS gehts ebenfalls ohne Verzögerungen.

Aber ich hab gerade mal eine Sidemap in openHAB getestet und auch da habe ich ne ziemliche Verzögerung.

Müsste also dann doch am openHAB Container liegen.

@Robert_Mini Okay diese Verzögerung bei einem Sprachbefehl ist ja vollkommen okay.
Bei mir hängts auch bei der Button Betätigung.

Könnt ihr mir evtl nochmal euren openHAB Knx thing Code zeigen. vlt hab ich da ja auch was falsch gemacht. Oder die Container einstellungen.
Timberwolf Server 950Q ID:317, VPN offen, Reboot nach Absprache

eib-eg
Reactions:
Beiträge: 231
Registriert: Fr Sep 14, 2018 5:03 pm
Hat sich bedankt: 1184 Mal
Danksagung erhalten: 115 Mal

#5

Beitrag von eib-eg »

Bitte deine TW Version in der Überschrift falls noch möglich ändern.

Auszug aus

viewtopic.php?f=8&t=331

Die Versionsnummer IMMER im Titel des Threads (am besten am Anfang wie [V 1.5.1] schreiben.

Danke für dein ( euer ) Verständnis.
Georg

TW 2600 #216 Vertrag Gold nur knx seit 1998 über ETS 1.36 Programm. VPN offen, Zugriff jederzeit
Antworten

Zurück zu „Docker Container: OpenHAB“