NEUHEIT! Ab sofort MQTT mit dem Timberwolf Server!
Verfügbar für alle Versionen mit der Insider Preview 5 zur Version 2.0. Infos: viewtopic.php?f=8&t=2846

[FINR] Kein Zugriff auf TWS über OpenVPN mit iOS Geräten (WD-1934)

Dies ist das Unterforum für die Funktionen rund um OpenVPN und den internen Proxy

Ersteller
MacLitze
Reactions:
Beiträge: 58
Registriert: Mo Mär 18, 2019 4:30 pm
Hat sich bedankt: 8 Mal
Danksagung erhalten: 9 Mal

Kein Zugriff auf TWS über OpenVPN mit iOS Geräten (WD-1934)

#1

Beitrag von MacLitze »

Moin!
Leider bekomme ich keine Verbindung zum TWS über VPN.
Habe das Nutzer-VPN eingeschaltet und konfiguriert.

OpenVPN Verbindung steht und ich kann den TWS anpingen. Aber nur mit der OVPN-IP 10.102.45.1

Wenn ich dann diese IP in den Browser eingebe wird der Login des TWS mit der Fehlermeldung „nicht erreichbar“ angezeigt.

Wenn ich über timberwolfxxx.local versuche den TWS zu erreichen kommt die Fehlermeldung das der Server nicht zu erreichen ist.

Für Tips wäre ich sehr dankbar!

Gruß
Kay
Zuletzt geändert von ms20de am Mi Jun 09, 2021 10:38 am, insgesamt 1-mal geändert.
TWS 950Q ID:318, VPN offen, Reboot erlaubt

StefanW
Elaborated Networks
Reactions:
Beiträge: 5634
Registriert: So Aug 12, 2018 9:27 am
Wohnort: Grafing
Hat sich bedankt: 2668 Mal
Danksagung erhalten: 4058 Mal
Kontaktdaten:

#2

Beitrag von StefanW »

MacLitze hat geschrieben: So Feb 28, 2021 7:45 amFür Tips wäre ich sehr dankbar!
Ja, es wäre sehr hilfreich die Software-Version anzugeben...

Ich denke, sehr viel weitere Angaben wären hilfreich, etwa, ob es den lokal ohne OpenVPN funktioniert use.


Stefan
Stefan Werner
Product Owner für Timberwolf Server, 1-Wire und BlitzART der Elaborated Networks GmbH
Support nur über dieses Forum und in individuellen Fällen über support@wiregate.de.
Bitte KEINE PN Impressum und Datenschutzerklärung oben

Ersteller
MacLitze
Reactions:
Beiträge: 58
Registriert: Mo Mär 18, 2019 4:30 pm
Hat sich bedankt: 8 Mal
Danksagung erhalten: 9 Mal

#3

Beitrag von MacLitze »

War unterwegs und konnte wegen mangelnder VPN-Verbindung nicht gucken ;)

Softwarestand ist 2.0 Insider Preview 3

Aus dem WLAN komme ich mit timberwolf318.local auf den Server.

Habe gerade aber auch gesehen das die Support-VPN nicht startet!
Fehlermeldung: Support_VPN offline: TLS Error
Bis zum Timberwolf Support sind die Pfeile grün.
Oder liegt das daran das ihr im Moment keine Verbindung zu meinem TWS aufbaut?
TWS 950Q ID:318, VPN offen, Reboot erlaubt

Ersteller
MacLitze
Reactions:
Beiträge: 58
Registriert: Mo Mär 18, 2019 4:30 pm
Hat sich bedankt: 8 Mal
Danksagung erhalten: 9 Mal

#4

Beitrag von MacLitze »

Ich bin mal wieder am probieren!
Support-VPN scheint nun wieder zu funktionieren.
Nachdem ich das gecheckt hatte, habe ich ein Update auf 2.0 Insider Preview 3.1 gemacht.
Support-VPN läuft immer noch.

Nun zu dem Problem:
- Nutzer-VPN-Dienst ist gestartet. Bei Internet steht 9.9.9.9 und beim Router wir die öffentliche IP angezeigt. Alle Pfeile sind grün.
- iPhone Wlan abgeschaltet
- Open-VPN gestartet und mit TWS verbunden
- Net Analyser findet den TWS und zeigt die IP 10.102.45.1 sowie den DNS-Namen "timberwolf318.local" an
Außerdem das iPhone mit der IP 10.102.45.2
- Die IP vom TWS kann auch angepingt werden
- Beim anpingen von timberwolf318.local kommt die Fehlermeldung "Failed to resolve IP address"
- Gebe ich die IP der VPN-Verbindung (IP 10.102.45.1) in den Browser ein kommt die Login-Seite mit der Fehlermeldung "TWS unerreichbar. Diese Information kann veraltet sein"
- timberwolf318.local wird vom Browser nicht geöffnet
- Das Zertifikat ist auf dem iPhone installiert
- Im Wlan kann ich auf den TWS zugreifen (aber nicht wenn die VPN-Verbindung noch aktiv ist)

Was kann ich noch tun?
TWS 950Q ID:318, VPN offen, Reboot erlaubt

Ersteller
MacLitze
Reactions:
Beiträge: 58
Registriert: Mo Mär 18, 2019 4:30 pm
Hat sich bedankt: 8 Mal
Danksagung erhalten: 9 Mal

#5

Beitrag von MacLitze »

Falls es hilft ist hier noch das Log-File der VPN-Verbindung:

2021-03-05 03:51:06 ----- OpenVPN Start -----
OpenVPN core 3.git::58b92569 ios arm64 64-bit

2021-03-05 03:51:06 OpenVPN core 3.git::58b92569 ios arm64 64-bit

2021-03-05 03:51:06 Frame=512/2048/512 mssfix-ctrl=1250

2021-03-05 03:51:06 UNUSED OPTIONS
5 [resolv-retry] [infinite]
6 [nobind]
7 [persist-key]
8 [persist-tun]
16 [verb] [3]

2021-03-05 03:51:06 EVENT: RESOLVE

2021-03-05 03:51:06 Contacting [x.x.x.x]:1194/UDP via UDP

2021-03-05 03:51:06 EVENT: WAIT

2021-03-05 03:51:06 Connecting to [DYNDNS_NAME]:1194 (x.x.x.x) via UDPv4

2021-03-05 03:51:06 EVENT: CONNECTING

2021-03-05 03:51:06 Tunnel Options:V4,dev-type tun,link-mtu 1557,tun-mtu 1500,proto UDPv4,keydir 1,cipher AES-256-CBC,auth SHA1,keysize 256,tls-auth,key-method 2,tls-client

2021-03-05 03:51:06 Creds: UsernameEmpty/PasswordEmpty

2021-03-05 03:51:06 Peer Info:
IV_VER=3.git::58b92569
IV_PLAT=ios
IV_NCP=2
IV_TCPNL=1
IV_PROTO=2
IV_AUTO_SESS=1
IV_GUI_VER=net.openvpn.connect.ios_3.2.3-3760
IV_SSO=openurl


2021-03-05 03:51:06 VERIFY OK: depth=1, /CN=timberwolf

2021-03-05 03:51:06 VERIFY OK: depth=0, /CN=timberwolf-user-vpn

2021-03-05 03:51:06 SSL Handshake: CN=timberwolf-user-vpn, TLSv1.2, cipher TLSv1.2 ECDHE-RSA-AES256-GCM-SHA384, 2048 bit RSA

2021-03-05 03:51:06 Session is ACTIVE

2021-03-05 03:51:06 EVENT: GET_CONFIG

2021-03-05 03:51:06 Sending PUSH_REQUEST to server...

2021-03-05 03:51:06 OPTIONS:
0 [dhcp-option] [DNS] [10.102.45.1]
1 [route-gateway] [10.102.45.1]
2 [topology] [subnet]
3 [ping] [10]
4 [ping-restart] [120]
5 [ifconfig] [10.102.45.2] [255.255.255.0]
6 [peer-id] [0]
7 [cipher] [AES-256-GCM]


2021-03-05 03:51:06 PROTOCOL OPTIONS:
cipher: AES-256-GCM
digest: NONE
compress: NONE
peer ID: 0

2021-03-05 03:51:06 EVENT: ASSIGN_IP

2021-03-05 03:51:06 NIP: preparing TUN network settings

2021-03-05 03:51:06 NIP: init TUN network settings with endpoint: x.x.x.x

2021-03-05 03:51:06 NIP: adding IPv4 address to network settings 10.102.45.2/255.255.255.0

2021-03-05 03:51:06 NIP: adding (included) IPv4 route 10.102.45.0/24

2021-03-05 03:51:06 NIP: adding DNS 10.102.45.1

2021-03-05 03:51:06 NIP: adding match domain ALL

2021-03-05 03:51:06 NIP: adding DNS specific routes:

2021-03-05 03:51:06 NIP: adding (included) IPv4 route 10.102.45.1/32

2021-03-05 03:51:06 Connected via NetworkExtensionTUN

2021-03-05 03:51:06 EVENT: CONNECTED [DYNDNS_NAME]:1194 (x.x.x.x) via /UDPv4 on NetworkExtensionTUN/10.102.45.2/ gw=[/]
TWS 950Q ID:318, VPN offen, Reboot erlaubt

Ersteller
MacLitze
Reactions:
Beiträge: 58
Registriert: Mo Mär 18, 2019 4:30 pm
Hat sich bedankt: 8 Mal
Danksagung erhalten: 9 Mal

#6

Beitrag von MacLitze »

Dann spekuliere ich mal weiter!

Es scheint ja etwas mit dem DNS-Server/Zertifikat zu tun zu haben.
Der DNS-Name timberwolf318.local wird nicht korrekt zur IP aufgelöst und im Zertifikat ist nur der DNS-Name hinterlegt.

Kann das so sein?

Wer ist denn der DNS-Server bei der VPN-Verbindung? Anscheinend der TWS.
0 [dhcp-option] [DNS] [10.102.45.1]
1 [route-gateway] [10.102.45.1]
2 [topology] [subnet]
3 [ping] [10]
4 [ping-restart] [120]
5 [ifconfig] [10.102.45.2] [255.255.255.0]
6 [peer-id] [0]
7 [cipher] [AES-256-GCM]
Wenn ich mit meinem "normalen" VPN-Zugang versuche auf den TWS zu kommen habe ich das gleiche Problem. DNS wird nicht gefunden/aufgelöst und mit der IP komme ich nicht auf den TWS, da das Zertifikat es nicht hergibt.
TWS 950Q ID:318, VPN offen, Reboot erlaubt

StefanW
Elaborated Networks
Reactions:
Beiträge: 5634
Registriert: So Aug 12, 2018 9:27 am
Wohnort: Grafing
Hat sich bedankt: 2668 Mal
Danksagung erhalten: 4058 Mal
Kontaktdaten:

#7

Beitrag von StefanW »

Hey Kay,

Nachdem was Du schreibst, scheint mir der Zusammenhang des Problems mit der nicht funktionierenden DNS Auflösung zusammenhängen.

Hat noch jemand das Problem?

Lg

Stefan
Stefan Werner
Product Owner für Timberwolf Server, 1-Wire und BlitzART der Elaborated Networks GmbH
Support nur über dieses Forum und in individuellen Fällen über support@wiregate.de.
Bitte KEINE PN Impressum und Datenschutzerklärung oben
Benutzeravatar

brinchi
Reactions:
Beiträge: 93
Registriert: So Aug 12, 2018 1:04 pm
Hat sich bedankt: 120 Mal
Danksagung erhalten: 73 Mal

#8

Beitrag von brinchi »

StefanW hat geschrieben: Sa Mär 06, 2021 12:47 pm Hat noch jemand das Problem?
Ja, wenn mich nicht alles täuscht (ist schon etwas her; s.u.), liegt das Problem auch bei mir vor.

Ich habe zwar schon vor langer Zeit die Versuche aufgegeben, mit iOS-Geräten und meinem Mac per VPN auf den TWS zuzugreifen, wäre aber durchaus dankbar für Lösungshinweise :pray:

Brian
timberwolf231 (2600), VPN offen, Reboot jederzeit

zitterfritz
Reactions:
Beiträge: 46
Registriert: Mi Dez 19, 2018 8:23 pm
Hat sich bedankt: 35 Mal
Danksagung erhalten: 24 Mal

#9

Beitrag von zitterfritz »

Hallo, ich hab auch das gleiche Problem und hab’s auch schon lang aufgegeben hier eine Lösung zu finden.
Würde mich aber freuen, wenn es mal gelöst würde.

Danke und Gruß

Heiko
TWS 960Q ID:230, VPN offen, Reboot erlaubt

StefanW
Elaborated Networks
Reactions:
Beiträge: 5634
Registriert: So Aug 12, 2018 9:27 am
Wohnort: Grafing
Hat sich bedankt: 2668 Mal
Danksagung erhalten: 4058 Mal
Kontaktdaten:

#10

Beitrag von StefanW »

Hallo Brian und Heiko,

dann werden wir da mal einen Blick drauf werfen.

Wenn es für Euch ok ist, würden wir aber vorher gerne noch den Modbus Geräte Manager ausrollen, damit man das neue Modbus Feature auch vollständig nutzen kann.

Wir würden - wegen der Effizienz - mithin so vorgehen wollen, dass wir uns während einerInsider Preview Phase zunächst darauf konzentrieren, das jeweils neue Hauptleistungsmerkmal (hier Modbus in der V 2.0) auszurollen. Wenn dies geschehen ist und die neue Funktionalität bei den Insidern reift, dann würden wir uns um die anderen Themen kümmern.

lg

Stefan
Zuletzt geändert von StefanW am So Mär 07, 2021 8:02 am, insgesamt 1-mal geändert.
Stefan Werner
Product Owner für Timberwolf Server, 1-Wire und BlitzART der Elaborated Networks GmbH
Support nur über dieses Forum und in individuellen Fällen über support@wiregate.de.
Bitte KEINE PN Impressum und Datenschutzerklärung oben
Antworten

Zurück zu „Timberwolf VPN & Proxy“