NEUES UPGRADE mit IP 8.1 verfügbar
4. Vorab-Version der Timberwolf VISU mit neuem Diagramm Design Assistenten und vielen Verbesserungen
Neues Backup V4 mit Sicherung Docker Volumes und Migration von 3xx/9xx auf TWS 3500 inkl. FIX mit 8.1
Hinweis: Neue Artikelserie zu Datensicherung / Wiederherstellung / Migration im Wiki online
Alle Infos zur neuen Insider Preview im Wiki: https://elabnet.atlassian.net/l/cp/LUJgwMg7

[Frage] [CV:0.12.6; TS V3.5.1] IP Cam einbinden

Rund um die CometVisu im Timberwolf Server
Antworten

Ersteller
Ziegelstein1
Reactions:
Beiträge: 12
Registriert: So Dez 03, 2023 2:45 pm
Hat sich bedankt: 4 Mal
Danksagung erhalten: 11 Mal

[CV:0.12.6; TS V3.5.1] IP Cam einbinden

#1

Beitrag von Ziegelstein1 »

Hallo Gemeinde,

ich versuche nun, meine IP-Cams wieder zum laufen zu bringen..(ging schon mal vor Jahren..)
Nun, neuer Server, aktuellste CV-Version.

Ausgangslage:
Ich hab verstanden, dass rtsp-streams irgendwie böse sind. Daher streame ich die Cam-Bilder über "Frigate" (= Videorekorder, auf TrueNAS Scale). Über Frigate wird automatisch die Anwendung "go2rtc" mit ausgeliefert. Diese Anwendung wandelt die CAM RTSP-Streams um, sodass ich diese im Browser aufrufen kann.
Funktioniert in Edge als auch Chrome mit folgendem Link z.B:
http://192.168.178.100:30058/live/webrt ... c=Haustuer.

Da das kein https-Link ist, hab ich mir gedacht, ich lass das über den TW-Proxy laufen.
Bild

Leider funktioniert das nicht. Kein Bild über:
https://timberwolf1251.fritz.box/proxy/Haustuer/

Am Ende funktioniert in der CV weder IMAGE oder Web Einbindung mit folgenden Links:
http://192.168.178.100:30058/live/webrt ... c=Haustuer.
oder:
https://timberwolf1251.fritz.box/proxy/Haustuer/

Cometvisu-Versuche:
<page name="Kameras" visible="false">
<web src="https://timberwolf1251.fritz.box/proxy/Haustuer/" width="500px" height="500px" frameborder="true" refresh="5" />
</page>

<image src="https://timberwolf1251.fritz.box/proxy/Haustuer/" />
</page>


In der Browser-Console wird angezeigt:
Bild

Nun benötige ich Hilfe.

Hilfe! :roll:

Viele Dank!
Zuletzt geändert von Ziegelstein1 am Mo Dez 18, 2023 10:02 pm, insgesamt 1-mal geändert.
Gruß Steve
_________________________________________________________
TWS 3500 ID:1251, 3x USB Busmaster, VPN offen, Reboot erlaubt

Cepheus73
Reactions:
Beiträge: 165
Registriert: Sa Aug 11, 2018 11:36 pm
Wohnort: München
Hat sich bedankt: 380 Mal
Danksagung erhalten: 108 Mal

#2

Beitrag von Cepheus73 »

Hallo Steve,

aus deiner Beschreibung ist mir nicht klar, ob schon die URL
https://timberwolf1251.fritz.box/proxy/Haustuer/
nicht funktioniert.
Wenn diese schon nicht funktioniert, dann geht natürlich die Einbindung in CometVisu erst recht nicht.

Aus dem Console-Log sieht man verschiedene Fehler.
Beim ersten Fehler mit dem Mixed Content geht es offenbar auf einen ganz anderen Server (192.168.178.200), dessen URL wegen http nicht akzeptiert wird.

Der zweite Fehler liegt vermutlich daran, dass der Server (welcher?) auf den Request für das Script "video-stream.js" mit einem HTTP Error Code antwortet (da kommt dann eine HTML-Seite mit dem Fehlercode als Text, was dann natürlich nicht passt zum erwarteten Script Content).

Grundsätzlich hat Reverse Proxying so seine Tücken, je nach dem wie der Source Web Content strukturiert ist. Wenn absolute URLs auf den ausgelieferten Seiten sind, dann müssen die ja auch umgeschrieben werden, das funktioniert nicht immer.

Viele Grüße

Bernhard
TW 2600 #178 - VPN offen, Zugriff jederzeit
EFH, KNX, 1-Wire, DALI, Wiregate,
CometVisu (TW Docker-Container), Mobotix T25, Logiken für Licht- und Rolladensteuerung
1-Wire-Ventilaktoren + Logiken für Gartenbewässerung

Ersteller
Ziegelstein1
Reactions:
Beiträge: 12
Registriert: So Dez 03, 2023 2:45 pm
Hat sich bedankt: 4 Mal
Danksagung erhalten: 11 Mal

#3

Beitrag von Ziegelstein1 »

Hallo Bernhard,

es ist so, dass dieser Link direkt im Browser funktioniert:
http://192.168.178.100:30058/live/webrt ... c=Haustuer

--> hier habe ich ein Bild. Leider ist das "nur" http. Ich hatte mir zurecht gelegt, dass das dann der Grund war, warum ich in der CV kein Bild habe, da ich dachte es müsse ein "https" - link sein.

Daher der Weg über den TW-Proxy. Leider funktioniert über den Proxy der neu erzeugte link auch nicht im Browser...und natürlich auch nicht in der CV.

Daraus die Frage:
Welche Bedingungen müssen erfüllt sein, dass die CV-Einbindung ein Bild wiedergibt?
"Vor Jahren" war das mal so: Wenn der Browser das Bild wiedergibt, dann auch über die CV. Nun haben sich aber wohl Anforderungen geändert.
Leider bin ich nicht fit genug, mit all den Protokollen fachgerecht umzugehen.

Mfg.
Gruß Steve
_________________________________________________________
TWS 3500 ID:1251, 3x USB Busmaster, VPN offen, Reboot erlaubt
Antworten

Zurück zu „CometVisu“