NEUES UPGRADE mit IP 8.1 verfügbar
4. Vorab-Version der Timberwolf VISU mit neuem Diagramm Design Assistenten und vielen Verbesserungen
Neues Backup V4 mit Sicherung Docker Volumes und Migration von 3xx/9xx auf TWS 3500 inkl. FIX mit 8.1
Hinweis: Neue Artikelserie zu Datensicherung / Wiederherstellung / Migration im Wiki online
Alle Infos zur neuen Insider Preview im Wiki: https://elabnet.atlassian.net/l/cp/LUJgwMg7

[Frage] [V4.0 IP5] Häufige Neuverbindungen verschiedener Systeme mit der KNX Schnittstelle des Timberwolfs

Diskussionen über die KNX-Funktionen im Timberwolf Server
Forumsregeln
  • Denke bitte an aussagekräftige Titel und gebe dort auch die [Firmware] an. Wenn ETS oder CometVisu beteiligt sind, dann auch deren Version
  • Bitte mache vollständige Angaben zu Deinem Server, dessen ID und dem Online-Status in Deiner Signatur. Hilfreich ist oft auch die Beschreibung der angeschlossener Hardware sowie die verwendeten Protokolle
  • Beschreibe Dein Projekt und Dein Problem bitte vollständig. Achte bitte darauf, dass auf Screenshots die Statusleiste sichtbar ist
  • Bitte sei stets freundlich und wohlwollend, bleibe beim Thema und unterschreibe mit deinem Vornamen. Bitte lese alle Regeln, die Du hier findest: https://wiki.timberwolf.io/Forenregeln
Antworten

Ersteller
Civlo
Reactions:
Beiträge: 2
Registriert: Mi Sep 06, 2023 8:56 pm
Danksagung erhalten: 2 Mal

[V4.0 IP5] Häufige Neuverbindungen verschiedener Systeme mit der KNX Schnittstelle des Timberwolfs

#1

Beitrag von Civlo »

Hallo zusammen,

ich beobachte seit kurzem (so um Weihnachten herum) ein seltsames Phänomen. Das hatte ich auch schon vor dem Umstieg auf Version 4.0, also auch schon mit der Version 3.5.1.

Im Wesentlichen sieht mein Setup so aus:

KNX Welt im Haus ist nur über den Timberwolf Server mit dem Netzwerk verbunden und wird auch über diesen parametriert. Dann habe ich noch weitere Systeme im Netzwerk, die über die Timberwolf Schnittstelle mit der KNX Welt kommunizieren. Diese Systeme sind die folgenden:

Timberwolf -> Docker -> NodeRed mit KNX Ultimate (IP: 172.17.0.3 mit bridge network / IP: 192.168.1.202 mit macvlan network)
Linux PC -> ProxMox -> LXC Container mit Docker/Portainer -> NodeRed mit KNX Ultimate (IP: 192.168.1.196)
Linux PC -> ProxMox -> LXC Container mit Home Assistant -> KNX Frontend (IP: 192.168.1.165)

Den NodeRed Container auf dem Timberwolf habe ich einmal im Bridge Modus betrieben und seit einem Tag habe ich das System auf Macvlan umgestellt und betreibe es seit dem so.

Prinzipiell kann ich auf meine KNX Welt zugreifen und Telegramme empfangen sowie Telegramme senden. Soweit so gut, was mir allerdings aufgefallen ist: Die Verbindungen dieser unterschiedlichen Systeme (beide NodeReds und Home Assistant) zu der KNX Schnittstelle des Timberwolfs werden sehr oft getrennt und neu aufgebaut (siehe Screenshot).

Bild

Im NodeRed habe ich solch einen Neuaufbau mal mitbekommen und diesen Screenshot mitgebracht:
Fehlermeldung: Disconnected by error Invalid Connection ID

Bild

Im Home Assistant schaue ich ins Log und finde folgende Einträge passend zum Zeitpunkt der Neustarts:

Bild

Beim Neuaufbau ist es dann so, dass die Systeme (NodeRed und Home Assistant) erstmal wieder ganz viele Lese Anfragen stellen, um den Status auf dem KNX Bus abzufragen. Das belastet den Bus in soweit, dass ich den Timberwolf Server aus der ETS heraus eigentlich gar nicht parametrieren kann. Dieser Vorgang an sich dauert ja schon lange und wenn man sich die Zeitabstände im 1. Screenshot anschaut (KNX LOG auf dem Timberwolf) dann wird klar, dass man hier kaum noch durchkommt. Auch bei anderen KNX Teilnehmern ist es mir schon aufgefallen, dass ich den Download Vorgang aus der ETS teilweise mehrfach anstoßen muss.

Die Frage ist nun: Hat jemand eine Idee, was das Problem hier sein kann? Für mich sieht es im Moment so aus, als läge es irgendwie am Timberwolf Server und der KNX Schnittstelle. Ich hoffe ihr könnt mir helfen.

Vielen Dank im voraus und viele Grüße,
Tarek
Zuletzt geändert von Parsley am Mi Jan 17, 2024 10:23 am, insgesamt 1-mal geändert.
Timberwolf 3500 #797 / VPN offen

gbglace
Reactions:
Beiträge: 3561
Registriert: So Aug 12, 2018 10:20 am
Hat sich bedankt: 1238 Mal
Danksagung erhalten: 1626 Mal

#2

Beitrag von gbglace »

Das ist relativ unabhängig vom TWS, da gibt es im KNX-UF auch im Zusammenhang mit anderen IP-Intertaces einige Beiträge. Dort gab es dann meist auch gleich blockierte Schnittstellen, da diese dort die Tunnel immer.nich was länger frei halten und dann mit 4-5 Tunnel die Kapazitäten schnell erschöpft sind.

Ursache waren Einstellungen im KNX-Adapter aber auch mal im Netzwerk selbst. Ich bin aber kein Netzwerkspezialist, um das genauer erklären zu können.
Grüße
Göran

#1 Timberwolf 2600 Velvet Red TWS #225 / VPN aktiv / Reboot OK
#2 Timberwolf 2600 Organic Silver TWS #438 / VPN aktiv / Reboot OK
#3 PBM 3 Kanäle, #4 Modbus-Extension

sfrit
Reactions:
Beiträge: 9
Registriert: Di Okt 31, 2023 8:29 pm
Hat sich bedankt: 2 Mal
Danksagung erhalten: 3 Mal

#3

Beitrag von sfrit »

Ich habe das gleiche Problem seit damals der Port von 3671 auf 3700 vom Interface geändert wurde.
timberwolf3500 L #685

Dragonos2000
Reactions:
Beiträge: 2178
Registriert: So Aug 12, 2018 1:38 pm
Wohnort: Karlsruher Raum
Hat sich bedankt: 479 Mal
Danksagung erhalten: 888 Mal

#4

Beitrag von Dragonos2000 »

Ich kenne NR und HA nicht: Kann man dort die Keep-Alive Intervalle einstellen und diese mal verkürzen (wenn möglich) ?
Man könnte zudem auch mal schauen, ob vor den Fehlern einige Zeit wenig/keine Kommunikation stattgefunden hat.
Lg
Jochen
____________________________________________________________
TW 2600 #188
VPN offen, Zugriff jederzeit, Experimente jederzeit, Reboot jederzeit

Dragonos2000
Reactions:
Beiträge: 2178
Registriert: So Aug 12, 2018 1:38 pm
Wohnort: Karlsruher Raum
Hat sich bedankt: 479 Mal
Danksagung erhalten: 888 Mal

#5

Beitrag von Dragonos2000 »

Und dann wäre noch die Frage, ob sich beeinflussen lässt, UDP (normaler Weise beim Routing) oder TCP (normaler Weise beim Tunneling) zu verwenden.
Lg
Jochen
____________________________________________________________
TW 2600 #188
VPN offen, Zugriff jederzeit, Experimente jederzeit, Reboot jederzeit

sfrit
Reactions:
Beiträge: 9
Registriert: Di Okt 31, 2023 8:29 pm
Hat sich bedankt: 2 Mal
Danksagung erhalten: 3 Mal

#6

Beitrag von sfrit »

Kurzes Feedback: Ich habe heute endlich mal Zeit gefunden das noch mal durchzuspielen und wollte das LOG vom iobroker KNX Adapter mit hochladen. Scheinbar haben sich bei mir die Probleme mit Update auf die [V4.0 IP7] der TWS-Software erledigt.

Moderation: Nach Austausch mit sfrit, habe ich die Versionsinformation entsprechend konkretisiert. :handgestures-salute:
Zuletzt geändert von blaubaerli am Sa Feb 03, 2024 1:02 pm, insgesamt 2-mal geändert.
timberwolf3500 L #685

blaubaerli
Reactions:
Beiträge: 2263
Registriert: Sa Sep 15, 2018 10:26 am
Wohnort: Kerpen
Hat sich bedankt: 869 Mal
Danksagung erhalten: 671 Mal

#7

Beitrag von blaubaerli »

Hallo @sfrit,

eine V4.0 ist schlicht noch nicht existent!

Beste Grüße
Jens
wiregate1250 & timberwolf168 (2600er), VPN offen, Reboot nach Vereinbarung

Mibr85
Reactions:
Beiträge: 482
Registriert: Mo Dez 02, 2019 5:38 am
Wohnort: Freital
Hat sich bedankt: 367 Mal
Danksagung erhalten: 183 Mal

#8

Beitrag von Mibr85 »

@Civlo
Besteht das Problem bei dir immer noch oder kann ich es auf gelöst setzen?
Grüße Micha

TWS 3500 XL #1209 + TWS 2600 #528 + PBM #972,
VPN offen, Reboot möglich
PLZ 01...
Antworten

Zurück zu „KNX“