NEUHEIT: Freigegebene Hauptversion V 1.6 ab sofort für alle Modelle des Timberwolf Server verfügbar. Infos: viewtopic.php?f=8&t=2588!

[Gelöst] [V 1.6 Hells Bells] Problem mit Programmierung von KNX Geräten

Diskussionen über die KNX-Funktionen im Timberwolf Server

Ersteller
terseek
Reactions:
Beiträge: 139
Registriert: Mi Sep 05, 2018 1:09 pm
Hat sich bedankt: 203 Mal
Danksagung erhalten: 68 Mal

[V 1.6 Hells Bells] Problem mit Programmierung von KNX Geräten

#1

Beitrag von terseek »

Guten Tag allerseits,

ich habe heute ein Problem, bei dem ich nicht mehr weiterkomme.

Ich wollte bei meinem Theben Dimmaktor DM 8-2 nur eine GA ändern, geht jedoch nicht, das Programmieren bricht mit der Meldung "Das Gerät antwortet nicht in angemessener Zeit." ab.

Habe das Gerät kurzzeitig vom KNX-Bus getrennt, dann Programmiertaste gedrückt, PA neu programmiert, kein Problem. Wieder probiert Applikationsprogramm zu laden, selber Fehler.

Da ich noch einen anderen Theben Dimmaktor habe, dachte ich, ich versuche den mal zu programmieren, gleiches Problem wie beim ersten.

Dann habe ich mal einen MDT Schaltkator, der auf dem gleichen Bus angeschlossen ist und sich in gleicher UV befindet, versucht zu programmieren; das geht prima ohne Problem.

Inzwischen schon mehrfach wiederholt ohne daß sich etwas am Problem ändert. Vom letzten Versuch habe ich mal einen Screenshot der ETS Fehlermeldung gemacht und einen vom KNX Busmonitor, siehe hier:
progfehler.jpg
knx trace.jpg
Ich hoffe, daß jemand von Euch eine Idee hat was die Ursache des Problems sein könnte.

Beste Grüße,

Peter
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
TWS 2600 ID:186 + 3 PBM, VPN offen, Reboot nach Vereinbarung

StefanW
Elaborated Networks
Reactions:
Beiträge: 5000
Registriert: So Aug 12, 2018 9:27 am
Wohnort: Grafing
Hat sich bedankt: 2360 Mal
Danksagung erhalten: 3691 Mal
Kontaktdaten:

#2

Beitrag von StefanW »

Hallo Peter,

es gab mal in der ETS einen Parameter, mit dem man auf "langsame Übertragung" (oder so ähnlich) schalten kann.

lg

Stefan
Stefan Werner
Product Owner für Timberwolf Server, 1-Wire und BlitzART der Elaborated Networks GmbH
Support nur über dieses Forum und in individuellen Fällen über support@wiregate.de.
Bitte KEINE PN Impressum und Datenschutzerklärung oben

gbglace
Reactions:
Beiträge: 1943
Registriert: So Aug 12, 2018 10:20 am
Hat sich bedankt: 634 Mal
Danksagung erhalten: 723 Mal

#3

Beitrag von gbglace »

Hi Peter,
Phänomene die hier und da bei solchen Meldungen ursächlich im Spiel waren:

-irgendwo in der Anlage ein knxd aktiv?
-Busspannungsversorgung an der Belastungsgrenze?
-LK auf dem Weg zum Aktor? (hier eher unwahrscheinlich)
-longframe support ggf. mal deaktivieren
Grüße
Göran

-- --Timberwolf 2600 Velvet Red-- -- TWS #225 / VPN aktiv / Reboot OK

Ersteller
terseek
Reactions:
Beiträge: 139
Registriert: Mi Sep 05, 2018 1:09 pm
Hat sich bedankt: 203 Mal
Danksagung erhalten: 68 Mal

#4

Beitrag von terseek »

StefanW hat geschrieben: Mi Jan 13, 2021 5:11 pm es gab mal in der ETS einen Parameter, mit dem man auf "langsame Übertragung" (oder so ähnlich) schalten kann.
Hallo Stefan,

danke, ja die Option heißt genau "Verwende reduzierte Bus-Kommunikation." Hatte ich auch schon probiert, allerdings vergessen zu schreiben.
gbglace hat geschrieben: Mi Jan 13, 2021 5:13 pm -irgendwo in der Anlage ein knxd aktiv?
Hallo Göran,

guter Punkt, ja hier läuft ein Container mit Cometvisu. Habe den mal deaktiviert, Problem bleibt jedoch bestehen.
gbglace hat geschrieben: Mi Jan 13, 2021 5:13 pm -Busspannungsversorgung an der Belastungsgrenze?
ETS sagt "40 Geräte auf dem Bus, Busstrom 430 mA". Stromversorgung ist MDT STR-0640, sollte also noch OK sein. Habe gerade gesehen, daß ich die Überwachungswerte der Spannungsversorgung noch gar nicht benutze; habe sie gerade mal mit Zeitserien verbunden und hier die Werte:

- Spannung 29,5 V
- Strom 274 mA

Klingt gut für mich.
gbglace hat geschrieben: Mi Jan 13, 2021 5:13 pm -LK auf dem Weg zum Aktor? (hier eher unwahrscheinlich)
nein
gbglace hat geschrieben: Mi Jan 13, 2021 5:13 pm -longframe support ggf. mal deaktivieren
Hm, kann ich nicht finden, wo kann man das deaktivieren?

Beste Grüße,

Peter
TWS 2600 ID:186 + 3 PBM, VPN offen, Reboot nach Vereinbarung

gbglace
Reactions:
Beiträge: 1943
Registriert: So Aug 12, 2018 10:20 am
Hat sich bedankt: 634 Mal
Danksagung erhalten: 723 Mal

#5

Beitrag von gbglace »

Ohne longframe ist wohl das gleiche wie die langsame Programmierung.

Auffällig ist leider das es verschiedene Aktoren gleichen Typs betrifft, sonst wäre man schnell dabei sagen zu können, defektes Gerät.
Grüße
Göran

-- --Timberwolf 2600 Velvet Red-- -- TWS #225 / VPN aktiv / Reboot OK

paralan
Reactions:
Beiträge: 149
Registriert: Mi Sep 05, 2018 11:49 pm
Hat sich bedankt: 151 Mal
Danksagung erhalten: 81 Mal

#6

Beitrag von paralan »

Hallo Peter,
hast du noch weitere Docker Container am laufen?
Falls ja würde ich diese mal stoppen.
Bei mir verhindert ein aktiver Openhab Container das Programmieren mancher KNX Geräte.
Gruß Alan

TWS 2600 ID:190; VPN offen; Reboot nach Absprache, da Beschattung über Logikeditor aktiv!

Ersteller
terseek
Reactions:
Beiträge: 139
Registriert: Mi Sep 05, 2018 1:09 pm
Hat sich bedankt: 203 Mal
Danksagung erhalten: 68 Mal

#7

Beitrag von terseek »

Das Programmieren geht wieder!

Nachdem ich nun alles überprüft hatte kam mir eine letzte Idee: der Timberwolf war während des ganzen Prozesses nie neu gestartet worden. Das habe ich nun getan und seitdem kann ich beide Theben Dimmer wieder programmieren.
TWS 2600 ID:186 + 3 PBM, VPN offen, Reboot nach Vereinbarung

eib-eg
Reactions:
Beiträge: 273
Registriert: Fr Sep 14, 2018 5:03 pm
Hat sich bedankt: 1222 Mal
Danksagung erhalten: 136 Mal

#8

Beitrag von eib-eg »

Hallo @terseek sowie alle.

Wie Stefan geschrieben hat im Update sogar in rot
Unter Punkt 2 Timberwolf Neustarten.

Frage an @terseek Peter

Hast du deinen Wolf nach dem Update wie Stefan geschrieben hat Neu gestartet ?
Georg

TW 2600 #216 Vertrag Gold nur knx seit 1998 über ETS 1.36 Programm. VPN offen, Zugriff jederzeit

Ersteller
terseek
Reactions:
Beiträge: 139
Registriert: Mi Sep 05, 2018 1:09 pm
Hat sich bedankt: 203 Mal
Danksagung erhalten: 68 Mal

#9

Beitrag von terseek »

Ich hatte VOR dem update neu gestartet, daß man danach auch neu starten soll, habe ich wohl übersehen.
TWS 2600 ID:186 + 3 PBM, VPN offen, Reboot nach Vereinbarung

StefanW
Elaborated Networks
Reactions:
Beiträge: 5000
Registriert: So Aug 12, 2018 9:27 am
Wohnort: Grafing
Hat sich bedankt: 2360 Mal
Danksagung erhalten: 3691 Mal
Kontaktdaten:

#10

Beitrag von StefanW »

Hallo,

ich hatte nur geschrieben, dass VOR dem Update neu gestartet werden sollte. Ob er danach auch zu starten war, würde dann von der Oberfläche nach den Update angezeigt, weil es hier drauf ankommt, welcher Server das ist und von welcher Version aus man updatet, da kann ich keine pauschale Aussage treffen. Erst gestern hatten wir einen Nutzer mit einer Anfrage, da läuft der Wolf noch mit der RC5 der V 1.5 vom September 2019.

Freut mich, dass das Problem behoben ist.


lg

Stefan
Stefan Werner
Product Owner für Timberwolf Server, 1-Wire und BlitzART der Elaborated Networks GmbH
Support nur über dieses Forum und in individuellen Fällen über support@wiregate.de.
Bitte KEINE PN Impressum und Datenschutzerklärung oben
Antworten

Zurück zu „KNX“